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Multiframe 8.63 29th April 2004 
 Release Note 
This release note describes the Windows version 8.63 of Multiframe, Steel Designer and 
Section Maker. This release contains numerous enhancements to this range of software.  
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Multiframe 

The following features have been modified or added to Multiframe in this release. 

Changes since v8.6 

 
Version 8.61 

• Unexpected dragging of members from a mouse click near the end of a 
member has been fixed. 

• Two new options have been added to the Preferences dialog to disable 
dragging of nodes and/or members in 3D views of the model. 

• Help files have been updated. 

• Panning in 3D views now displays the correct panned image. 

Version 8.62 

• Zoom rectangle no longer leave trail on screen when dragging without the 
mouse button depressed. 

• Two new options have been added to the Preferences dialog to disable 
snapping to member midpoints and the display of grid snap text tip. 

• Ctrl+Tab now iterates through windows again. 

• Clipping bars now draw correctly when dragged. 

• Extra redraw of selection in when using selection rectangle has been 
eliminated. 

• Grid icon in toolbar has been revised. 

• Mismatched tolerance for snapping to joints has been corrected.  

Version 8.63 

• Fixed a problem with mouse wheel zoom 

• Corrected display of rendering in Plot window in some circumstances 

• Combined load cases can now change design classification 

• File associations for .mfd now work in al cases 
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Grouping 

Multiframe now allows the grouping of members by the user. Members can be grouped 
via the Add Group command in the Select menu. Groups may be deleted or edited and 
members may also be added or removed from an existing group via other commands in 
the Select menu. 
 
Often it is convenient to group members in more than one way. For example, members 
may be grouped by floor or by a frame line in a building. To assist in this, Multiframe 
allows you to manage groups as group sets. In the example, separate group sets would 
be used to contain the groups defining floors and the groups defining frames.  By 
default, a single group set is created when starting a new frame or opening an old file. 
 

 
 
Only a single group set may be active within the user interface at one time. All 
commands for adding, editing and deleting groups will act on the groups in the current 
group set. The active or current group set is specified via the Current Group Set 
submenu in the Select menu or via the list in the new Groups toolbar. 
 
The members belonging to each group in the set can be displayed by selecting to display 
members by group colour via the Symbols dialog. If a member belongs to more than 
one group it will be displayed in the colour of the first group to which it belongs. In 
general this can be avoided by the appropriate use of groups sets. 
 

Drawing Grid and Structural Grids 

The existing drawing grid used within Multiframe has been improved. Grid lines are 
now drawn as solid light grey lines and grid snap has been modified to only snap to the 
grid when the cursor is close to a grid point. 
 
To compliment the drawing grid, the user can now define structural grids representing 
the grid lines of a building. Any number of these grids may be added to the model to 
represent floors or frame lines.  As with the drawing grid, the structural grids provide a 
means of constraining drawing and dragging of items to specified locations in 3D space.  
This will make it easier to create a structure using a 3D view. 
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The definition of structural grids is controlled using the Grid Manager dialog that is 
displayed using the Structural Grids command from the View menu. This dialog is used 
to add, edit or delete grids from the current model. For each grid the user is able to 
specify the plane in which the grid lies, the position of the grid, the location and label of 
the grid lines and the colour used to draw the grid.  

 
To modify a grid, click on the row corresponding to a grid and then click the Edit 
button. This will display a dialog allowing you to modify that grid. 
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Frame Generation 

The generation of common structural forms has been significantly improved in this 
release and now include various forms of trusses, portal frames, grillages and frames. 
The Generate command from the Geometry menu now allows you to select from a range 
of common structure types. 

 
Generation of structures has also been improved to allow for supports and other 
features to be specified. For the generation of a rectangular frame, both secondary and 
tertiary beams can now be automatically created. 
 

Rendering 

OpenGL rendering has been enhanced to allow the user to select the level of detail to 
which section shapes are represented. Low level of detail will render section shapes as a 
number of flat plates with no representation of the web or flange thicknesses.  Medium 
detail displays the true 3D outline of the section shape including thickness as modelled 
by a series of rectangular plates while a high level of detail models the true 3D outline of 
the section including the fillets, circular corners and rounded edges.  
 
The level of detail is set via the remodelled Render dialog. 
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The OpenGL rendering has also been modified to use a full lighting model in which 
shading to the model is produced by lights located around the structure.  An option for 
controlling the lighting is provided in the Rendering dialog. Lighting can also be 
controlled via a new Rendering toolbar that allows up to 4 lights to be toggled on or off.  
 

Analysis and Plotting Performance 

The speed of analysis has been significantly improved by optimising the order of 
member loads. For large frames, this has resulted in a reduction of analysis times of up 
to 75%. The same optimisation has also improved the time taken to display global 
diagrams of member actions. The generation of moment diagrams for some larger 
models has been reduced by more than a factor of 12.  
 

Automation Interface 

The Multiframe automation interface has been updated to support the features added to 
the program since the original version of the interface.  Modifications to the library 
include 

• New library version – Version 1.1 

• Added objects representing group sets and groups 

• Support for new section shapes added since Multiframe version 8 

• Support for new section properties added since Multiframe version 8 

• Access to additional modal solver properties 

• Access to participation factors via modal results 

• Expose CopyWindow method of application object 

• Support for new plot types added since Multiframe version 8 

• Add UserData for Elements and Joints 

Please refer to the Multiframe Automation manual for full details on each of this items. 
 
IMPORTANT – After upgrading to the new version of Multiframe it will be 
necessary to reset the reference to the Multiframe object library so that it uses the 
new version of the object library.  This will need to be done in all scripts, macros 
and applications that access the Multiframe object library. Failing to do this will 
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result in unexpected errors when executing scripts that reference the Multiframe 
object library. 
 

Accelerator Keys 

The following changes have been made to the accelerator keys; 
• Insert key replaces Ctrl+I to add a new member  

• Ctrl+Insert adds a continuous member  

• Home key performs a size to fit.  This command can still be access via Ctrl+t  

 

Spring Members 

An element for modelling an elastic connection between two joints has been added to 
Multiframe. A Spring Member is a special member that represents a spring connected 
between the two Joints. Unlike a normal beam/column member, there is no coupling of 
the actions along the members so the spring stiffness of the spring in each direction acts 
independently of the others. 
 
A spring member is added to a model by drawing the member using the Add Spring 
Member command in the Geometry menu. The properties of the spring can be edited by 
double clicking on the member or by specifying the stiffness of the spring via the Spring 
Member Stiffness command in the Frame menu. All stiffness’s are specified in the local 
coordinate system of the member. 
 

 
No loads can be applied to spring members. After analysis, the computed actions in 
spring members are not plotted but can be viewed via the Spring Member Actions table 
in the Result Window. 
 

Subdividing Intersecting Members 

A new command has been added to subdivide intersecting members. The Geometry-> 
Intersect Members command will find the intersection of all selected members and 
subdivide the members at each intersection point. The location of intersections is 
computed in 3D space. 
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Select Menu 

The View->Select submenu has been moved to the main menu. The new Select menu 
contains enhanced selection commands as well as new commands for managing groups. 
 

Exchanging Selections between views 

In some situations it is convenient to find members or joints by sorting tables in the Data 
or Results windows. In the past it has not been possible to select these items in any other 
window. To facilitate the selection of items in other windows, new commands have 
been added to set the selection in one view to be equal to, or extended to include, the 
selection in another view. The selection in the current view can be set equal to that in 
another by selecting that view from Select->From View submenu. The selection in the 
current view will be extended to include the selection in the other view if the shift key is 
held down when executing one of these commands. 
 

Joint Link Groups 

The definition of joint link groups now stores a list of the elements selected when the 
group is created. If an element contained within a joint link group is subdivided, the 
new joints will automatically be added to the group. 
 
The joints and elements stored within a Joint Link group can now be selected via the 
Joint Link command in the Selection menu.  
 

Legends and Colour 

Drawing in the Frame window has been enhanced by the introduction of a number of 
options for choosing the colour used to draw each member displayed within the 
window and a legend to show the meaning of those colours.  

 
You can turn on or change the colours using the Symbols command from the Display 
menu or by using the right popup menu associated with the legend.  

 
The options are – 
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• No Colour scheme – Members all drawn in black 

• By Section – Each section used in the frame is allocated a different colour. 
Members are coloured according to their section. 

• By Section Group – Each section group from which sections are used is drawn 
in a different colour. Member are coloured according to the group in which their 
section is located. 

• By Shape – Members are drawn in a colour depending upon the shape of the 
section. Each section shape is automatically allocated a different colour. 

• By Label – Each unique member label used within the frame is allocated a 
different colour. Members are colour according to their label. 

• By Type – Each different type of member is drawn in a different colour. 

• By Group – Members are drawn in the colour of the first group they belong to in 
the current group set. 

 
If you turn on the option to display the Legend, a colour legend will be drawn in the top 
right corner of the Frame window. You can double click on a name in the legend to 
select items of that type. You can double-click on a colour in the legend change that 
items colour.  
 
A number of formatting options are also available via a popup menu displayed when 
right clicking the mouse on the legend.  
 

Dragging Joints in 3D 

Joints can now be dragged in a 3D view.  Unless the joint is dragged over and snapped 
to another joint or structural grid point, it will move in a plane passing the drawing 
depth that is parallel to the two global axis that are most perpendicular to the direction 
from which the model is currently viewed.  These axes can easily be identify as they are 
highlighted in a double thick line on the global axes icon. 
 
While dragging working in the 3D view of the model, the crosshair are now displayed 
running parallel to the global axes so as to help align points in the model. 
 

Reverse member axes 

A new “Reverse Member Ends” command has been provided to reverse the joints that 
define the ends of a member. This has the effect of reversing the direction of the 
member axes.  This menu item is located within the Advanced submenu of the 
Geometry menu. 
 

Adding Multiple Point Loads 

All the dialogs for adding point loads to a member now permit several locations to be 
specified in the distance field. Each location should be separated by a comma. For 
example you could enter L/3, L/2, 2*L/3 in the distance field to add 3 loads to a member.  
On exit from the dialog the new loads will be added at each of the specified locations. 
 

Add Joints 

A new advanced geometry command has been created to enable the user to add a joint a 
specific position.  
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Align Joints 

Another advanced geometry command has been added for aligning joints to a specified 
position. The Align Joints command will move all the selected joints such that one 
component of the joints positions will set equal to a specified value. 

 
 

Load Plots 

Local plots of loads about a member’s major or minor axis can now be displayed in the 
Plot Window. 

 
The variation of distributed loads along the member is plotted in terms of the member’s 
local coordinate system. Superimposed on this diagram are the locations of point loads 
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applied to the member. For plots of loads along design members, the loads applied to 
joints internal to the member are also displayed. Note that the point loads are not drawn 
to scale and that only point loads with components applied parallel to the axis of the plot 
are displayed. 
 

Member Plot View 

The local member plot view now displays the maximum actions along the member in 
the bottom right hand corner of the window. It also displays the position of the 
crosshair as measured from the right hand end of the member. 
 

Double Angle and Angles shapes 

Double angle and angle sections aligned about their principal axes are now supported 
within Multiframe as standard section shapes. For unequal angles, the angle between the 
principal axes and the geometric axes aligned with the legs of the angle needs to be 
included in the sections library data to ensure the angles are displayed correctly. 
 

Preview of Section Shapes 

The Section Type dialog in the Frame menu now displays a preview of each section 
shape when it is selected in the list of sections. 

 
 

Tension/Compression Only springs 

The functionality of joint springs has been extended and now allows for springs to be 
applied in terms of the global coordinate system or the local coordinate system of the 
joint to which they are attached.  In addition, springs may also be specified as acting in 
tension or compression only. This is a non-linear effect and will only be considered 
in a non-linear analysis in which tension/compression only effects are considered. 
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Engineering Format 

The format of real numbers can now be displayed in engineering format. This format 
displays the number in an exponential format but limits the exponents to be multiples of 
three. 

 

Steel Designer 

The following features have been modified or added to Steel Designer in this release. 
 

BS5950 

Steel Designer now supports design of rolled and welded sections to the British 
Standard BS5950 “Part 1- Structural use of steelwork in buildings”.  Full details of this 
code are contained within the Steel Designer manual.   
 

Acceptance Ratio 

For design checks to AS4100, LRFD or BS5950, the efficiency at which a design check 
on a member is deemed to have failed can now be modified to values other than 100%. 
This value is known as the Acceptance Ratio. The acceptance ratio for a member is set 
via the Design->Options command. 
 
Note that the acceptance ratio is only applied to strength design checks and is not 
considered when checking deflections or in the application of design constraints. 
 

Efficiency Plots 

The graphical presentation of design results has been improved via the introduction of a 
new colour scale, new legend, and support for OpenGL rendering. 
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The new colour scale for displaying design efficiencies highlights members that have 
failed or are near failure. Member that have just failed but are within 5% of the 
acceptance ratio are shown in orange. Members with efficiencies exceeding this are 
shown in red except for members that failed to be designed due to an error which are 
displayed in magenta. Members that have passed but have an efficiency within 5% of the 
acceptance ratio are shown in yellow. All other members with a successful design are 
shown in a colour scale that varies from blue to yellow.  
 

 

Section Maker 

The following features have been modified or added to Section Maker in this release. 
Version 8.63 

• Fixed a problem with tapered section placement 

• Corrected units display in Place Shape dialog 

 

Plastic Modulus 

Section Maker now computes the plastic modulus of the shape drawn in the Shape 
Window.  The plastic modulus about the x-x, y-y and the principal axes are all 
computed and displayed in the Properties Window. 
 

Warping Constant 

The value of the warping constant is now evaluated for shapes that Section Maker can 
identify as one of the standard shapes supported within the program. The calculation of 
the warping constant in based on empirical equations and provides a close estimate of 
the true value. For any shape not recognised as a standard shape, the warping constant 
will be set to zero.  
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Composite Sections 

The evaluation of section properties for composite sections is now performed using the 
modular ratio theory. The user may select the material used as the reference material via 
the “Reference Material…” command in the Shape menu. 
 

Menu Rationalisation 

A large number of changes have been made to the menu to make it more intuitive.  
• The Properties, Polygons, Circles and Rectangle menu items have been moved 

from the Display menu into the new Display->Data submenu. 

• The menu items for displaying graphic symbols have been moved into the new 
Display->Symbols submenu from both the Display and View menus .   

• The Edit->Clear command has been renamed to Delete.  

• The Shape menu has been split in two, all commands in relation to manipulating 
the geometry of a shape have been moved into a new Geometry menu. 

• The Install command has been renamed to “Add to Library…” 

• The Taper menu item has been moved to the Library menu and renamed 
“Generate Tapered Sections…” 

• The Section menu has been renamed the Library menu 

• The Material main menu has been moved to be a submenu in the Library menu. 
The Select Material command has been moved to the Shape menu and renamed 
to “Material…”.  Furthermore, the Remove Material command has become 
redundant and has been removed.  

• A new Group submenu has been created in the Library menu.  This menu now 
contains the all the commands for adding, editing, deleting and reordering of 
groups, sections and fields. 

 

Tapered Shapes 

Tapered flange sections are now supported within Section Maker. The representation of 
tapered shapes assumes that the flange thickness is the thickness of the flange computed 
midway between the tip of the flange and the web.  
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New Standard Sections 

New standard section shapes have been added to support double angles sections and 
angles described about their principal axes.  

   
 

New Section Properties 

The following section properties can now be stored within the library    
r0  - Polar radius of gyration about shear centre. 
H  - Flexural constant as defined by Appendix E of AISC LRFD design code. 
k  - Distance from outer face of flange to toe of fillet on web. 
k1 - Distance from outer centre of web to toe of fillet on flange. 
Qf - Statical moment of the flange. 
Qw - Statical moment of the web. 
xp - x position of equal area axis used in computing plastic modulus as 

measured from centroid. 
yp - y position of equal area axis used in computing plastic modulus as 

measured from centroid. 
 
A number of addition fields have also been added for storing the dimensions of shapes. 
These allow for the description of more complex shapes. 

t1 - Additional thickness dimension. 
t2 - Additional thickness dimension. 
s - Spacing dimension. 
taper - Flange taper angle. 
 

In addition, there are five (5) user properties that may be used to store any property not 
supported within the library.  These properties will be displayed in the terms of the base 
unit set used within Section Maker and Multiframe. 
 

Property Window 

The Property window has changed from a single table view to a multi-table view that 
contains new tables displaying specific subsets of the section properties. The user now 
has the choice of viewing tables containing properties relevant to the geometric axes, the 
principal axes, or just the dimensions of the section. In addition, there are also tables 
that display all section properties, the properties of the current group selected within 
Section Maker or the properties of the Frame group used within Multiframe. The last 
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two groups can be used to help exchange section property data with Multiframe via cut 
and Paste into the Multiframe Add or Edit section dialogs. 
 
Note that the section properties in the Group Table are displayed in the units of the 
current group.  All other tables are displayed using the current units selected within 
Section Maker. 
 

Default Material 

A default material is now assigned to shapes drawn in the Shape Window.  The default 
material is specified via the Select Material dialog. This dialog now has an option to set 
the selected material as the default material. 

  
When the application starts or a new library is opened the default material is reset to no 
material. 
 

New Polygon Commands 

Two new commands have been added to assist in building complex shapes. The first of 
these commands allows the user to merge one or more closed polygons into a single 
shape. The second command complements the Merge command and allows the user to 
convert shapes other than polygons into closed polygons. 
 
The merging of polygons will join all connecting or overlapping closed polygons. In 
doing so it considers if each of the polygons is solid or forms a hole. As such, the result 
of merging polygons may not be a single polygon but a number of polygons. 
  

Align, Stack and Size commands 

New commands have been added to the Geometry menu for the alignment of shapes 
within the Shape Window. Shapes can now be moved to align the sides or centres of all 
the shapes selected within the Shape Window.  
 
Selected shapes can now be moved to align the shapes side by side or on top of one 
another via the new Stack commands. The Stack Horizontal command will move shapes 
horizontally such that the left and right edges of adjacent shapes are aligned to one 
another. Similarly, the Stack Vertical command will move shapes such that the top and 
bottom sides of adjacent shapes and aligned. 
 
Three other commands are now available via the Geometry menu for resizing shapes to 
make them equal in width, height or in both directions. 



Multiframe v8.63 Release Note 

Page 17 

 
For all these commands, shapes will be resized or aligned to the shape that was selected 
first. A Geometry toolbar incorporating all these commands has also been added to the 
user interface. The display of this toolbar can be toggled via the View->Toolbars 
submenu. 

 
 

Colours and Legends 

Drawing in the Shape window has been enhanced by the introduction of a number of 
options for choosing the colour used to draw each shape displayed within the window.  
 

• No Colour scheme – Shapes all drawn in black 

• By Shape – Each shape or section is drawn in an individual colour. 

• By Material – Each shape is drawn in the colour of it’s material. 

• By Shape Type – The type of shape (i.e. box, tube, polygon, etc.) is used to 
determine the colour in which a shape is drawn. 

 
A feature of the legend is that all items corresponding to a particular item in the legend 
can be selected by simple double clicking on the text of that legend item. In most cases 
the colour of a legend item can be changed by simply double clicking on the colour box 
associated with each item. 
 

 
  

Symbols 

The display of symbols has been rationalised with the grouping of all symbol commands 
into a new Symbols submenu. A new Symbols toolbar has also been added to provide 
access to many of these commands. 
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Shape Dimensions 

The overall dimensions of a shape may now be displayed in the Shape Window. In 
addition, internal dimensions showing the position of the centroid can also be shown in 
this window. The display of these dimension are toggled via the command in the 
Display->Symbols submenu.   

  
 

Copy and Paste Shapes 

Shapes selected within the Shape Window can now be cut, copied and pasted within the 
window.  The duplicate shapes will be inserted into the window offset slightly from the 
original shapes. 

  
 
Note that the existing behaviour of the copy command to place an image of the windows 
contents onto the clipboard has been preserved. 
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Duplicating Groups 

A new command has been added for creating a duplicate of a group. The group that is 
currently displayed in the Group Window can be duplicated using the Library->Groups-
>Duplicate command. This command adds a new group to the library and all properties 
of the current group and sections within this group are then copied to the new group. 
 

Section Mover 

When groups are moved between libraries using Section Mover, any materials 
referenced by the sections in that group will also be moved to the destination library if a 
corresponding material does not already exist in that library. 
 

Drawing Grid 

The existing drawing grid used within Section Maker has been improved. Grid lines are 
now drawn as solid light grey lines and grid snap has been modified to only snap to the 
grid when the cursor is close to a grid point. 
 

Graphical Enhancements 

A number of graphical enhancements have been made to the program to improve the 
look and feel of the program when drawing or dragging within the Shape window.  
 

Problems Fixed  

This version fixes the following problems experienced with previous versions of 
Multiframe, Steel Designer or Section Maker. 

 
• Efficiency plots were not refreshed when design data was modified. 

• Design tables in Result and Data windows were not refreshed when design data 
was modified. 

• Orientation of section shapes in rendering was incorrect. 

• Headings of last two columns in Member Efficiency table for AS4100 where 
incorrect. 

• Best Section can now be edited via Efficiency Table in Result Window. 

• Ctrl+A selects all in Report Window. 

 

Problem Reports 

We greatly appreciate any bug reports or suggestions we receive, please keep them 
coming.  Please continue to report any bugs or anomalies you find: 
 
Fax:  +61 8 9335 1526  Email: support@formsys.com 
 
You can also lodge your problem reports via our web site at the following location: 
http://www.formsys.com/Multiframe/MFSupport/MFProblemReport.html 
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When emailing reports, please attach the frame and sections library with your message. 
 


